I suggest you ...

Stop loading of tweets I've already read on startup

When I start up Twhirl, first it takes every bit of processing away from everything else, and then my screen FILLS with popups...Some are new, but the majority are those I have already read, marked as seen, and trashed. This included ALL of my direct messages, and most of the @s from days past...This has GOT to stop! If' I've marked it as read, I DON'T WANT TO SEE IT AGAIN!

303 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    JindaiJindai shared this idea  ·   ·  Admin →
    under review  ·  marco.kaiserAdminmarco.kaiser (Admin, twhirl) responded  · 

    twhirl should not notify you about tweets you have seen in a previous session by default – this is controlled by a setting in the account configuration. It will still download “old” tweets when you start it, to give you some context, but those messages should neither be marked as new nor give you notifications.

    We will look into this issue and find our why you might see notifications for those old tweets.

    18 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Gary OwenGary Owen commented  · 

        I've found the same thing as the previous commenter. If I close twhirl before shuting down Windows then the "As Read" post list is updated. If I shut down windows without closing twhirl first then all the posts are marked as new the next day, even if the "Mark New As Seen" button has been pressed.

      • Daniël SchenkDaniël Schenk commented  · 

        To me this only happens if Twhirl was closed by Windows shutdown. When i first close Twhirl, and then start it again, or at next Windows bootup, i don't have this problem.

      • daftm1daftm1 commented  · 

        Same issue here. I set up for receiving sound/pop-up notifications for repies and DM's. Twhirl aways notifies me even for oldest messages.

      • ross.masonross.mason commented  · 

        Same issue here - no notifications on startup selected and still each time I load up I am bombarded with popup notifications. Can you fix please?

      • Ariya BAriya B commented  · 

        I've selected "no notifications for old messages on start" and this still happens at every startup.

      • wolfgang.stoehlerwolfgang.stoehler commented  · 

        It's really ridiculous to show me 35 days old replies I wouldn't like remembered of. At every startup of TWHIRL I've to delete at least 200 tweets I already have seen.
        Shouldn't it be easy to remember a timestamp of the oldest displayed tweet at shutdown of TWHIRL and newer show tweets older? Think about it! And thanks in advance for implementing such a mechanism.

      • Deren SmithDeren Smith commented  · 

        Option I would like to see; would be if the twitter message was marked 'as seen'. Then the next time I startup Twirl, that message will be shown. Unless say I click on the down arrow or a some UI element that says show all.

      • gingerbbm#gingerbbm# commented  · 

        I'm just lurking round these parts, but it strikes me that everyone's getting very upset about a piece of free software. Sure, this forum exists to request changes, but shouting is plain rude.

      • misangelamisangela commented  · 

        Sorry, montuos, but "no notifications on startup" is what DOES NOT work. Every time I start up, there are all the old tweets. Please fix this ASAP!

      • petemahonpetemahon commented  · 

        @ultimatebuster - it's still under review, not completed - give the Seesmic boys a chance, 0.9 is still better!

      • kemiekemie commented  · 

        This worked very briefly on 0.8.2, broke on the next version and has not been fixed since. very annoying.

      • GLR444GLR444 commented  · 

        You are right: it doesn't work correctly. It should exactly work like in your request, which it doesn't. On restart I have the whole screen full of tweets and messages which are ages old, and they come again and again. It causes a totally wrong impression of having received new tweets and/or messages. This is a clear error and is in fact annoying.

      • JindaiJindai commented  · 

        Montuos...I already HAVE That option checked, why do you think I demand this so vehemently? It doesn't WORK, and I want it to work.

      • petemahonpetemahon commented  · 

        Montuos - the problem is not with notifications only. I regularly mark my messages as read and then clear my screen. If I shut down and restart, twhirl does not remember which ones I have cleared. I get all my messages again, marked with a star. Takes ages to find out which ones I've read.

      • montuosmontuos commented  · 

        If you don't want the popups when you start twhirl, go to Configuration, select the Notify tab, and check "no notifications for old messages on start".

      • IDisposableIDisposable commented  · 

        This needs to be combined with the other request to load more than 20 messages at startup so you can essentially see all the new messages after Twhirl has shutdown and restarted. Additionally, would be awesome to store this "read high water mark" somewhere on the web so my phone and various machines all know what I've seen.

      • kurtisnelsonkurtisnelson commented  · 

        I wish if you mark something as read it dissipates off to a read window, and behaved more like Google Reader

      Feedback and Knowledge Base